quarta-feira, junho 28, 2006

Dapper em um AMD64-X2 - Aplicações de 32 bits

Dia de finalizar e emboiolar o sistema. Para não encher mais o saco, vamos ao resumo: instalei o Acrobat Reader 7.0.8, flash e plugin Java de 32 bits (o Openoffice também é 32bits mas não há opção de escolha e a instalação é transparente para o usuário). O plug-in do Blackdown Java 1.4, disponível no Dapper, fecha o Firefox (e o Mozillão) quando tentam acessar o applet do Banco do Brasil, portanto impraticável por estas bandas. O resto está todo em 64 bits ;) Os pacotes com as bibliotecas de 32 bits são: ia32-libs, ia32-libs-gtk, ia32-libs-openoffice.org, ia32-libs-sdl e ia32-sun-java5-bin (este está no Multiverse).

O Firefox-32, eu baixei o pacote do Ubuntu e Hardware., do Alexandre Otto Strube. Depois de instalado o pacote, com o sudo dpkg -i, rodei o sudo firefox32 para atualizar (Ajuda-> Verificar Atualizações). Tudo funcionou, de prima...

Do repositório do Marillat, eu baixei o acroread, mozilla-acroread e acroread-escript 7.0.8, que são mais atuais que o Dapper. Lembre-se da dica, baixe o pacote em uma máquina de 32 bits (ficam no /var/cache/apt/archives) e copie-os para a máquina de 64 ;)
(poucos usuários tem a oportunidade de rodar em uma máquina com tantos bits quanto o ano de nascimento!) . O comando para instalar arquiteturas diferentes é


$ sudo dpkg -i --force-architecture acroread-xxx.x.i386.deb


Garimpando no fórum do Ubuntu, baixei o mplayer32 do site do Grannas. Do repositório do Marillat, baixei o w32codecs e não deixei de ver nenhum dos meus p0rn movies.

Finalmente o skype: para não ter aporrinhações baixei o skype-beta_staticQT-1.3.0.30.tar.bz. Descompactei no meu próprio diretório e rodei o skype lá dentro. Sem problemas.... O som que gravei no TestCall estava baixo mas com boa qualidade. O dinâmico vai sentir falta da qt-mt, mas quanto menos KDE e qt, melhor ;) Quem sabe um dia crio um pacote: tá bom, crio agora. Aproveite e baixe o .deb na página do Skype. Siga os passos abaixo
mkdir tmp
dpkg -e Desktop/skype-beta-1.3.0.30-1_i386.deb tmp/DEBIAN
dpkg -x Desktop/skype-beta-1.3.0.30-1_i386.deb tmp
tar -jxvf skype-beta_staticQT-1.3.0.30.tar.bz2
cp skype-1.3.0.30/skype tmp/usr/bin/skype
cp skype-1.3.0.30/skype-callto-handler tmp/usr/bin/
vi tmp/DEBIAN/control
dpkg -b tmp/ Desktop/skype-beta-1.3.0.30-1_amd64.deb
sudo dpkg -i Desktop/skype-beta-1.3.0.30-1_amd64.deb

Na etapa do vi tmp/DEBIAN/control, substitua i386 por amd64 e retire as libqt das dependências.

5 Comentários:

Às 10 julho, 2006 09:47 , Blogger Antonio Costa disse...

Acabei de instalar o Ubuntu Dapper num AMD64. Quase todas as aplicações de 32 bits funcionaram perfeitamente. A única exceção é o plugin java do Firefox32, que capota com o applet do BB.

 
Às 18 julho, 2006 18:11 , Anonymous Anônimo disse...

O site www.charges.com.br funciona com o firefox32 (no outro, estava horrível), porém não tem som. Como resolvo isso? Cassiano.

 
Às 18 julho, 2006 18:44 , Blogger Thadeu Penna disse...

Tente
sudo aptitude install alsa-oss
e edite o /etc/firefox/firefoxrc colocando
FIREFOX_DSP=”aoss”

 
Às 24 junho, 2007 01:33 , Blogger paulokunde disse...

Deu tudo certinho, mas qdo vou executar o skype ocorre o seguite erro: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory

 
Às 24 junho, 2007 10:32 , Blogger Thadeu Penna disse...

Oi Paulo,

eu não sei que distribuição você está usando, mas no Debian Etch bastaria instalar
apt-get install lib32asound2

Faltam as bibliotecas do ALSA para 32 bits. No Dapper (na época em que postei o artigo) elas estavam no ia32-libs, mas depois foram desmembradas.

 

Postar um comentário

Assinar Postar comentários [Atom]

Links para esta postagem:

Criar um link

<< Página inicial